Ошибка Postfix — SMTPUTF8 is required.

  • Twitter
  • Facebook
  • Google+
  • Linkedin
  • Vkontakte

При использовании функции PHP mail () на VPS/VDS с ОС Linux , иногда возникают ошибки с отправкой писем, и в лог — файлах мы видим следующие записи:

(/var/log/mail.log)

date mail postfix/smtp[....]: 0D.2D....D0: to=<user@example.com>, relay=Other_mail_Server[1.2.3.4]:25, delay=0.51, delays=0.04/0.04/0.42/0, dsn=5.6.7, status=bounced (SMTPUTF8 is required, but was not offered by host Other_mail_Server[1.2.3.4])

Официальная документация http://www.postfix.org/SMTPUTF8_README.html, и гласит она, что нужен Postfix версии выше 3-ки, я так думаю это уже давно не проблема.

Проверить это можно командой:

smtputf8_enable = no
smtputf8_autodetect_classes = all

У меня у самого 3.x.x , только перешел с версии 2.

Я пробовал изменять main.cf

Даже дописал строчки:

postconf mail_version

smtputf8_enable = no
smtputf8_autodetect_classes = all

как это помогло не знаю, так как видимого результата это не принесло, и я продолжил поиски, которые привели меня к простым командам:

Но вот команды

postconf smtputf8_enable=no

postfix reload

И счастье, даже не смотря на compatibility_level = 2 в main.cf.

Так что думаю, что этот параметр, запрашивал именно мой почтовик.

Добавить комментарий

Ваш email не будет виден, и требуется, только для обратной связи.
Поля обязательные к заполнению *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.